$re = '/^(?!123456789|987654321)\d{9}$/m';
$str = '000000001
0000000001
123456789
987654321';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);