$re = '/(\w+\'?\s*)+[-|~]\s*((\d+\.?\d+\$?)|(\$?\d+\.?\d+))/';
$str = '**LOOKING FOR PAYPAL OFFERS ON THESE PAINTED UNCOMMONS**';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);