re = /(?<=[&?]Ntt=)(?:%20&%20|[^&])*/m
str = '?Ntt=crockett%20&%20Jones&Rdm=718&searchType=simple&type=search&Ns=&N=&Nrpp=12&No=0&Nr=AND(product.active:1,NOT(record.type:Store))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end