re = /<(.+?)class=\s*"(.+?)"/m
str = '<h1 class="big blue" id="testing"> some text </h1>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end