re = /^(?:http(s)?:\/\/)?[\w.-]+(?:\.[\w\.-]+)+[\w\-\._~:?#[\]@@!\$&'\
(\)\*\+,;=.]+$/m
str = 'www.teste'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end