re = /\b(
# MAC address like xx:xx:xx:xx:xx:xx
[0-9a-f]{2}:[0-9a-f]{2}:[0-9a-f]{2}:[0-9a-f]{2}:[0-9a-f]{2}:[0-9a-f]{2}
|
# MAC address like xx-xx-xx-xx-xx-xx
[0-9a-f]{2}-[0-9a-f]{2}-[0-9a-f]{2}-[0-9a-f]{2}-[0-9a-f]{2}-[0-9a-f]{2}
|
# MAC address like xxxx.xxxx.xxxx
[0-9a-f]{4}\.[0-9a-f]{4}\.[0-9a-f]{4}
|
# IPv4 address in dotted-quad format
# Not a lot of value for our needs in checking range of each octet
# Need to be more mindful of performance here anyway.
\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}
)\b/ix
str = '192.168.1.2
10.0.0.0
ff:ff:ff:ff:ff:ff
FF-FF-FF-FF-FF-FF
FFFF.FFFF.FFFF
ffff.ffff.ffff
blah127.0.0.1haha
foo127.0.0.1
'
subst = '\\1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result