$re = '/^(\d)(?!\d*\1$)\d*$/m';
$str = '121
123
121
1233
1441
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);