use strict;
my $str = 'foob
ar';
my $regex = qr/(?<!\d)\R/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";