#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<([a-z\-]+)>{([ \w\.-]+)} *(.*?)<\/\1>"
Local $sString = " <p>{.lead} Prose is great." & @CRLF & _
"</p>" & @CRLF & _
"" & @CRLF & _
"<blockquote x="attr">" & @CRLF & _
" <p>{.quoted .para}A <strong>danger</strong>ous blockquote.</p>" & @CRLF & _
"</blockquote>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")