import re
regex = re.compile(r"^(?:(?:\+|00)?(55)\s?)?(?:\(?([0-0]?[0-9]{1}[0-9]{1})\)?\s?)??(?:((?:9\d|[2-9])\d{3}\-?\d{4}))$", flags=re.MULTILINE)
test_str = ("91234-1234\n"
"1291234-1234\n"
"12 91234-1234\n"
"12 912341234\n"
"(12) 91234-1234\n"
"(12) 912341234")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")