re = /(\ {|\s+\}|:(?= )|;)/
str = '.fixed-feedback-block {
position: fixed;
right: 0;
top: calc(50% - 33px);
cursor: pointer;
.inner {
text-indent: 10px;
}
svg {
width: 50px;
position: absolute;
top: 15px;
left: 0;
z-index: 85;
height: 20px;
}
.call-me-button {
width: 240px;
height: 50px;
display: block;
background: #f35556;
transform: translate3d(190px, 0, 0);
transition: transform 0.3s ease-out;
border: none;
box-shadow: none;
border-radius: 0;
&:hover {
transform: translate3d(0px, 0, 0)
}
}
.write-to-us-button {
width: 215px;
height: 50px;
background: #00a5b8;
float: right;
transform: translate3d(165px, 0, 0);
transition: transform 0.3s ease-out;
border: none;
box-shadow: none;
border-radius: 0;
&:hover {
transform: translate3d(0px, 0, 0)
}
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end