re = /^(?:I)?([A-Z].+?)(?:ActivityArguments|$)/
str = 'IIStemTest1ActivityArguments'
# Print the match result
str.match(re) do |match|
puts match.to_s
end