re = /The puctuation character in the ASCII table are: \Q!"#$%&'()*+,-.\/:;<=>?@[\]^_`{|}~\E/m
str = 'The puctuation character in the ASCII table are: !"#$%&\'()*+,-./:;<=>?@[\\]^_`{|}~
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end