import re
regex = re.compile(r"STARTKEYWORD (.+?)(?:$| ENDKEYWORD$)", flags=re.MULTILINE)
test_str = ("STARTKEYWORD some text I want to extract ENDKEYWORD\n"
"STARTKEYWORD some text I want to extract")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")