$re = '/\(([^)]*)\)/m';
$str = 'I\'m (Kid J)
From (Detroit), (Michigan)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);