$re = '/\b\w*(?<![yz])[yz]\b/';
$str = 'fez day fyyyz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);