$re = '/^[^A-Za-z]+/';
$str = '1234 123423-34 This is a test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);