using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(\d+)(st|nd|rd)";
        string substitution = @"nth";
        string input = @"Liverpool to score 2 goals in 1st 90 minutes
";
        RegexOptions options = RegexOptions.Multiline;
        
        Regex regex = new Regex(pattern, options);
        string result = regex.Replace(input, substitution);
    }
}