#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+(?:[ \t]\w+)*[ \t]+V\d{1,2}\.\d{1,2}[ \t]+(?:3[01]|[12][0-9]|0[1-9])\/(?:1[0-2]|0[1-9])\/(?:20)?[0-9]{2}"
Local $sString = "hardware -v" & @CRLF & _
"...(need to ignore junk here in case there is any)" & @CRLF & _
"MyHardware V1.23 01/02/20 (This is the only line I need)" & @CRLF & _
"PROCESSOR:xxxxxxxxxx" & @CRLF & _
"abc <n> <c> [r] " & @CRLF & _
"def <n> <c> [r]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"MyHardware V1.23 01/02/03" & @CRLF & _
"MyHardware V12.34 01/02/03" & @CRLF & _
"MyHardware V1.23 01/02/2003" & @CRLF & _
"MyHardware V12.34 01/02/2003" & @CRLF & _
"" & @CRLF & _
"My Hardware V1.23 01/02/20"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")