$re = '/^(?=[\s\S]*WORD1)(?=[\s\S]*WORD3)(?:[\s\S]*\n)?\K.*WORD2/';
$str = 'Report Name
Report Date
Blah blah blah
Blah: WORD1
Blah blah
blah blah: WORD2
blah blah
blah blah: WORD3
blah blah
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);