package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d`)
var str = `azerty
1azerty
aze2rty
azerty3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}