package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)F[A-Z]{0,2}`)
var str = `F
FAB
FAA
FAZ
FAAA
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}