import Foundation
let pattern = #"(?=(((Ard.|Lorr.) *?:|;) *([^;:]{0,100}) (\([0-9/, -]{0,10}/[0-9/, -]{0,10}\)), *([^;]{0,250}?),* *(([0-3]?[0-9]\.)?[01]?[0-9]\.[0-9]{2,4}), *([^;]{0,150}?) *(;|\) ?\.) ( ?ibid\., *(([0-3]?[0-9]\.)?[01]?[0-9]\.[0-9]{2,4}), *([^;]{0,50}) *(;|\) ?\.))*))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
en août, ni sur ceux récoltés ensuite (16.10.2014, M. Garnier-Delcourt & J. Thorn), peut-être parce que les sporophores étaient un peu dégradés par les intempéries ? Cortinarius emollitoides Bidaud, MoënneLocc. & Reumaux (Fig. 2) = C. galeobdolon Melot sensu auct. ; C. causticus Fr. sensu. auct. non Brandrud et al. (1998) Ard. : Consthum, Fridbësch (71/113), plantation d’Abies et de Picea, 12.11.2012, Ch. Reckinger 319 (h) ; ibid., 23.9.2014, Ch. Reckinger 405 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h). Dans le sous-genre Myxacium (Fr.) Trog, qui regroupe en principe des cortinaires à chapeau et pied visqueux, la section Vibratiles Melot se distingue par l’amertume de la cuticule et généralement aussi de tout le sporophore. Elle comprend des espèces assez colorées (en jaune-brun ou rougebrun) ou peu co
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)