re = /^(?P<local>[a-zA-Z0-9.!#$%&'*+\/=?^_\x60{|}~-]+)@(?P<domain>[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?(?:\.[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?)+)$/m
str = 'me@example.com
me@example.co.uk
me@example.new
me@example'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end