$re = '/^(\-?\d*\.?\d{0,}?)$|^(\-?\.\d+)$/m';
$str = '12
1.2
.12
12.12
-12
-1.2
-.12
-12.12
unwanted:
#12
“12
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);