$re = '/\[([A-Z]{3})\s(\d{4})\]/m';
$str = 'What is your family Occupation? [RMB 2011]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);