$re = '/(?<=^[A-Za-z0-9]{2}).*?(?=@)/m';
$str = 'email@domain.com
ansianin@abc.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);