package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d+\.\d{2}$`)
var str = `1000.02`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}