import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\+?6)?\\ ?0\\ ?\\d{1,2}\\-?\\s?\\d{3,4}\\s?\\d{4}";
final String string = "03-2222 3333\n"
+ "04-222 3333\n"
+ "010-222 3333\n"
+ "011-2222 3333\n\n"
+ "011 2222 3333\n\n"
+ "+60 3-2222 3333\n"
+ "+60 4-222 3333\n"
+ "+60 10-222 3333\n"
+ "+60 11-2222 3333\n\n"
+ "+60 11 2222 3333\n"
+ "+6011 2222 3333\n"
+ "+6011-2222 3333\n\n"
+ "60102223333\n"
+ "601122223333\n"
+ "0102223333\n"
+ "01122223333\n\n"
+ "+60322223333\n"
+ "+6042223333\n"
+ "call 012-0000 0000 now";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}