package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z]{2}\|[|\w]*[A-Z]\s+(.*?)\s+OS=`)
var str = `sp|Q2UVX4|CO3_BOVIN Complement C3 OS=Bos taurus OX=9913 GN=C3 PE=1 SV=2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}