const regex = /[a-z]{2}\|[|\w]*[A-Z]\s+(\S*(?:\s(?!\s*OS=)\S*)*)\s+OS=/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-z]{2}\\|[|\\w]*[A-Z]\\s+(\\S*(?:\\s(?!\\s*OS=)\\S*)*)\\s+OS=', 'gm')
const str = `sp|Q2UVX4|CO3_BOVIN Complement C3 OS=Bos taurus OX=9913 GN=C3 PE=1 SV=2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}