re = /(\|\d+)\1(?:((?:\|\d+)*)\1)?(?=\||$)|^(\d+)\|(?=\3\b)/m
str = '0612|0613|061|0612|0612
0211|0612|021|0212|0211|0211
0111|0111
0511|0512|0511|0511|0521|0512|0511'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result