$re = '/\b\w{0,2}(?!((.)\2+)(?!.*\1)|ed)([aeiou]\w+)-?\w\w?\3\b/m';
$str = 'pow-wow
pickwick
easy-peasy
nitty-gritty
bzzzzzzz
mmmmmm
shish
wedged
yaaaaaa
choochoo
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);