#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)--last-value [0-9]{4}-[0-9]{2}-[0-9]{2} [0-9]{2}:[0-9]{2}:[0-9]{2}.[0-9]"
Local $sString = "19/09/09 10:34:37 INFO tool.ImportTool: --incremental append" & @CRLF & _
"19/09/09 10:34:37 INFO tool.ImportTool: --check-column DTIN" & @CRLF & _
"19/09/09 10:34:37 INFO tool.ImportTool: --last-value 2019-07-27 00:00:00.0" & @CRLF & _
"19/09/09 10:34:37 INFO tool.ImportTool: (Consider saving this with 'sqoop job --create')"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")