# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^ (?<Desc>[\s\S]*?) (?<QteComm>(?:[0-9]+)) (?<QteRecu>(?:[0-9]+)) (?<QteBO>(?:[0-9]*)) [$](?<PrixUnitaireF>(?:[0-9]+)\.(?:[0-9]+))[\s]+(?:(?<Escompte>(?:[0-9]+).(?:[0-9,]+)) %)?[\s]+(?<total_item>(?:[0-9]*[,]?[0-9]+)\.(?:[0-9]+))[\s]+[\r\n|\r|\n])"
test_str = ("Date commandée Date de facture Commandé par Expédié par Votre numéro de commande\n"
"04-OCT-2022 05-DÉC-2022 LIVRE DIRECT 786q23teqwuye\n"
"Date d'expédition No. de compte No. Commis Notre No. commande\n"
"No. livraison manuel\n"
"05-DÉC-2022 358 MIB 21q24242456013\n"
"Quantité\n"
"Prix\n"
"No. Produit Description Escompte Montant\n"
"Commandé Livré unitaire\n"
"Souffrance\n"
"e e\n"
" 32_SSL-\n"
" PNI SSL-LH/480/20/40/287/DC/D 112 112 $73211.4800 8,022.44 \n"
"LHB3/170/40/120/3\n"
" 32_SSL- PNI AlloCie SSL-\n"
" 6 6 $2.2700 17.48 \n"
"LHB3/LV2/12V/CO LHB3/LV2/12V/CONTROLLER2\n"
" 32_SSL-\n"
" PNI AlloCie SSL-LH/LV/90V/SEN3erw2 175 175 $3.1100 4,044.25 \n"
"LH/LV/90V/SEN\n"
" livrer direct ref: s245354-5235 \n"
" \n"
" \n"
" \n"
" \n"
" \n"
" \n"
" \n"
" \n"
" \n"
" \n"
" \n"
" \n"
" \n"
" \n"
" \n"
" \n"
"SOUS-TOTAL $1,041.31 \n"
"TRANSPORT $0.00 \n"
"FRAIS DIVERS $0.00 \n"
"T.P.S. $151.07 \n"
"T.V.Q. $296.38 \n"
" \n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.