#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Maximum amplitude:\s*(-?\d\.\d+)\n"
Local $sString = "Samples read: 6615000" & @CRLF & _
"Length (seconds): 75.000000" & @CRLF & _
"Scaled by: 2147483647.0" & @CRLF & _
"Maximum amplitude: 0.712219" & @CRLF & _
"Minimum amplitude: -0.805969" & @CRLF & _
"Midline amplitude: -0.046875" & @CRLF & _
"Mean norm: 0.009264" & @CRLF & _
"Mean amplitude: -0.000027" & @CRLF & _
"RMS amplitude: 0.043011" & @CRLF & _
"Maximum delta: 0.734100" & @CRLF & _
"Minimum delta: 0.000000" & @CRLF & _
"Mean delta: 0.008353" & @CRLF & _
"RMS delta: 0.041470" & @CRLF & _
"Rough frequency: 6767" & @CRLF & _
"Volume adjustment: 1.241"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")