import re
regex = re.compile(r"^Maximum amplitude:\s*(?P<amp>-?\d\.\d+)\n", flags=re.MULTILINE)
test_str = ("Samples read: 6615000\n"
"Length (seconds): 75.000000\n"
"Scaled by: 2147483647.0\n"
"Maximum amplitude: 0.712219\n"
"Minimum amplitude: -0.805969\n"
"Midline amplitude: -0.046875\n"
"Mean norm: 0.009264\n"
"Mean amplitude: -0.000027\n"
"RMS amplitude: 0.043011\n"
"Maximum delta: 0.734100\n"
"Minimum delta: 0.000000\n"
"Mean delta: 0.008353\n"
"RMS delta: 0.041470\n"
"Rough frequency: 6767\n"
"Volume adjustment: 1.241")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")