$re = '/.+?register\/\d+/';
$str = 'http://localhost:8888/wachigroup/#!/register/73';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);