$re = '/(00)+$/m';
$str = '99990000
11100000
22220000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);