use strict;
my $str = '/**
Contributors: Charles Staich
Match Confidence: Low
Language: Regular Expressions (regex)
Language Version:
Flags:
Purpose: Match CUI Basic and CUI Specified. Note the importance of evaluating multiple possible labels, such that CUI Specified may also be considered if this pattern matches. CUI Specified requires *at least* the same protections as CUI Basic (citation needed).
Assumptions: CUI Basic and CUI Specified documents contain the phrase \'CUI\'
Plain English Pattern Narrative:
Case sensitive, and does not match \'cui\'.
Indiscriminately matches any single instance of the word* \'CUI\' without any additional qualifiers, context, or markings necessary (Low Confidence)
Capturing Group(s): None
Definitions:
Word: A string of alphanumeric characters surrounded by word boundaries (\\b).
Comments:
Do not use this in Production without heavy testing.
I realize now why the community has taken to using the word cooey. I\'m certain there have been many collective hours spent reviewing false positive matches they created through filing standards, policy, communications, and documentation.
**/
// PATTERN:
\\bCUI\\b
// POSITIVE CASES:
CUI
asdf CUI jkl;
This document does not contain CUI.
This portal is not permitted to be used for transferring CUI.
No CUI allowed.
===CUI===
(CUI)
***CUI***
^CUI^
!CUI!
~CUI~
CUI//SP-TEST
CUI//TEST
// NEGATIVE CASES:
cui
0CUI-
ACUI*
-CUI2
CUi CuI cUI
AAACUIAAA
Cooey
Circuit
CIRCUIT
CUISP
';
my $regex = qr/\bCUI\b/mxsup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}