re = /(?<!\S)(?:(?:[1-9]?\d|1\d\d|2[0-4]\d|25[0-5])\.?\b){4}(?!\S)/m
str = '1555.2655.3255.1594 256.1.2.3
0.0.0.0 1.2.3.4 255.0.0.1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end