const regex = /(?<!\S)(?:(?:[1-9]?\d|1\d\d|2[0-4]\d|25[0-5])\.?\b){4}(?!\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)(?:(?:[1-9]?\\d|1\\d\\d|2[0-4]\\d|25[0-5])\\.?\\b){4}(?!\\S)', 'gm')
const str = `IP-salata 1555.2655.3255.1594 0.0.0.0 256.1.2.3 1.2.3.4 255.0.0.1 tomata
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}