re = /https?:\/\/\S+?\.top\b/m
str = 'b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top\', b\'http://p27dokhpz2n7nvgr.1jw2lx.top\', b\'p27dokhpz2n7nvgr.1jw2lx.top'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end