package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)z[éè]ro`)
var str = `zéro
zèro
zero`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}