use strict;
my $str = 'href="https://blogger.googleusercontent.com/img/a/AVvXsEhb-vB59M2NTWyWvDlMemRdgT0XMKdjB4NMH02iP4Nb7HbzHwq5ZObxjEC1_oLne6xpUhIkrkpyWEdMX9ck-aU5h1JXdpSw-GhbV90QBEi2xigGLQdoSswWuQtPNNCyWMRJiT2XnEadx170jUDbtL-AQKKzYyarCoj8=s1727"
src="https://blogger.googleusercontent.com/img/a/AVvXsEhb-vB59M2NTWyWvDlMemRdgT0XMKdjB4NMH02iP4Nb7HbzHwq5ZObxjEC1_oLne6xpUhIkrkpyWEdMX9ck-aU5h1JXdpSw-GhbV90QBEi2xigGLQdoSswWuQtPNNCyWMRJiT2XnEadx170jUDbtL-AQKKzYyarCoj8=w400-h183"';
my $regex = qr~https://blogger\.googleusercontent\.com/img/a/[^/\s'"]+~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}