$re = '/^\(0\d\)\d{8}$/m';
$str = '(01)12345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);