# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"src=([\"'])(?<url>(?:https?:)?\/\/(?:(?!\1).)*?)\1"
test_str = "<iframe style=\"border: 1px solid rgba(0, 0, 0, 0.1);\" width=\"800\" height=\"450\" src=\"https://www.figma.com/embed?embed_host=share&url=https%3A%2F%2Fwww.figma.com%2Ffile%2FuZVQhh9JQIziU1cSg3CSne%2FRich-Text-and-Embed-Dev%3Fnode-id%3D101%253A8445\" allowfullscreen></iframe>"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.