re = /(Q\.\W*\d{1,2}\W*Incontournable.*?)(?=Q\.)/m
str = 'Q. 1 Incontournable Cercle 1 _ 30 - Gestion Actif / Passif \\nQuel est le dispositif de limites de l’établissement ? Quels indicateurs sont retenus ? Sont-ils \\npertinents ? a-t-il été validé par le Comité des risques ? Quelle est la fréquence de revue des \\nindicateurs et des limites associées ? (revue a minima annuelle prévue par l’article 224 de l’arrêté \\ndu 3 novembre 2014) ? \\n Cliquez ici pour taper du texte. \\n \\n \\n \\n Q. 2 _ ☐ \\nCe dispositif respecte-t-il les normes du Groupe BPCE ? \\n \\n Q. 3 Incontournable Cercle 1 _ 30 - Gestion Actif / Passif \\nQuel dispositif se déclenche en cas de dépassements des limites ? L’établissement informe-t-il la \\nDRCCP, conformément au Référentiel des Risques de marché Groupe, du plan d’action mis en place \\nafin de revenir dans les limites ? L\\\'information a-telle été remontée au comité des risques et d\\\'audit \\nde l\\\'établissement ? \\n Contrôle & Test \\nS’assurer de l’existence de procédures de gestion des dépassements de limite incluant \\nnotamment les alertes et les plans de retour dans les limites. Vérifier que ce dispositif est \\ndocumenté, présenté au Comité des Risques de l’établissement et communiqué à la \\nDirection des Risques locale ainsi qu’à la DRCCP BPCE. \\n \\n Q. 4 _'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end