use strict;
my $str = '60 040 Ламінат Vitality Deluxe 4V 8/32 Дуб Берлі (2.162 м2)/9шт.
60 328 Ламінат Vitality Deluxe 4V 8/32 Дуб Амбарний (2.162 м2)/9шт.
60 491 Ламінат Vitality Deluxe 4V 8/32 Дуб Вибілений (2.162 м2)/9шт.
60 542 Ламінат Vitality Deluxe 4V 8/32 Дуб Елегантний (2.162 м2)/9шт.
60 544 Ламінат Vitality Deluxe 4V 8/32 Горіх Селект (2.162 м2)/9шт.
60 581 Ламінат Vitality Deluxe 4V 8/32 Дуб Суперіор (2.162 м2)/9шт.
60 583 Ламінат Vitality Deluxe 4V 8/32 Дуб лакований натур. (2.162 м2)/9шт.
60 584 Ламінат Vitality Deluxe 4V 8/32 Дуб Авеню (2.162 м2)/9шт.
60 619 Ламінат Vitality Deluxe 4V 8/32 Дуб Білий промаслений (2.162 м2)/9шт.
60 624 Ламінат Vitality Deluxe 4V 8/32 Ясень садовий (2.162 м2)/9шт.
60 796 Ламінат Vitality Deluxe 4V 8/32 Дуб пісочний (2.162 м2)/9шт.
60 900 Ламінат Vitality Deluxe 4V 8/32 Дуб сірувато-димчастий (2.162 м2)/9шт.
60 902 Ламінат Vitality Deluxe 4V 8/32 Дуб Iпанема (2.162 м2)/9шт.
60 903 Ламінат Vitality Deluxe 4V 8/32 Дуб Замшевий (2.162 м2)/9шт.
60 904 Ламінат Vitality Deluxe 4V 8/32 Дуб Сумі (2.162 м2)/9шт.
60 909 Ламінат Vitality Deluxe 4V 8/32 Дуб ретушований (2.162 м2)/9шт.
Vitality Style 4V
135 Ламінат Vitality Style 4V 8/32 Дуб Дуб Вибілений Сонячний (2.179 м2)/9шт
137 Ламінат Vitality Style 4V 8/32 Дуб Вікторіанський Коричневий (2.179 м2)/9шт
138 Ламінат Vitality Style 4V 8/32 Дуб Натуральний Бежевий (2.179 м2)/9шт
145 Ламінат Vitality Style 4V 8/32 Дуб Модерн Білий (2.179 м2)/9шт
148 Ламінат Vitality Style 4V 8/32 Дуб Чорний (2.179 м2)/9шт
174 Ламінат Vitality Style 4V 8/32 Дуб Медовий (2.179 м2)/9шт
177 Ламінат Vitality Style 4V 8/32 Дуб Морозний (2.179 м2)/9шт
178 Ламінат Vitality Style 4V 8/32 Дуб Модерн Вишуканий (2.179 м2)/9шт
179 Ламінат Vitality Style 4V 8/32 Дуб Гірський Сірий (2.179 м2)/9шт
135 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Дуб Вибілений Сонячний
137 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Вікторіанський Коричневий
138 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Натуральний Бежевий
145 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Модерн Білий
148 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Чорний
149 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Сірий океан
174 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Медовий
175 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Брендон
177 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Морозний
178 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Модерн Вишуканий
179 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Гірський Сірий
';
my $regex = qr/([0-9,\s]+) (Ламінат|Акція\sЛамінат) (.+ \d+(?:\/\d+|[A-Z]+)?|\d+|\d+\/\d+) ([^\(]+) /mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}