#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(К?[0-9 ]+)(?:| \([0-9() м]+\)) (?:Ламінат|Акція Ламінат) ([A-Za-z0-9\/( .]*[\d)]) (.+?)(?: \(\d|\s*$)"
Local $sString = "60 040 Ламінат Vitality Deluxe 4V 8/32 Дуб Берлі (2.162 м2)/9шт." & @CRLF & _
"60 328 Ламінат Vitality Deluxe 4V 8/32 Дуб Амбарний (2.162 м2)/9шт." & @CRLF & _
"60 491 Ламінат Vitality Deluxe 4V 8/32 Дуб Вибілений (2.162 м2)/9шт." & @CRLF & _
"60 542 Ламінат Vitality Deluxe 4V 8/32 Дуб Елегантний (2.162 м2)/9шт." & @CRLF & _
"60 544 Ламінат Vitality Deluxe 4V 8/32 Горіх Селект (2.162 м2)/9шт." & @CRLF & _
"60 581 Ламінат Vitality Deluxe 4V 8/32 Дуб Суперіор (2.162 м2)/9шт." & @CRLF & _
"60 583 Ламінат Vitality Deluxe 4V 8/32 Дуб лакований натур. (2.162 м2)/9шт." & @CRLF & _
"60 584 Ламінат Vitality Deluxe 4V 8/32 Дуб Авеню (2.162 м2)/9шт." & @CRLF & _
"60 619 Ламінат Vitality Deluxe 4V 8/32 Дуб Білий промаслений (2.162 м2)/9шт." & @CRLF & _
"60 624 Ламінат Vitality Deluxe 4V 8/32 Ясень садовий (2.162 м2)/9шт." & @CRLF & _
"60 796 Ламінат Vitality Deluxe 4V 8/32 Дуб пісочний (2.162 м2)/9шт." & @CRLF & _
"60 900 Ламінат Vitality Deluxe 4V 8/32 Дуб сірувато-димчастий (2.162 м2)/9шт." & @CRLF & _
"60 902 Ламінат Vitality Deluxe 4V 8/32 Дуб Iпанема (2.162 м2)/9шт." & @CRLF & _
"60 903 Ламінат Vitality Deluxe 4V 8/32 Дуб Замшевий (2.162 м2)/9шт." & @CRLF & _
"60 904 Ламінат Vitality Deluxe 4V 8/32 Дуб Сумі (2.162 м2)/9шт." & @CRLF & _
"60 909 Ламінат Vitality Deluxe 4V 8/32 Дуб ретушований (2.162 м2)/9шт." & @CRLF & _
"Vitality Style 4V" & @CRLF & _
"135 Ламінат Vitality Style 4V 8/32 Дуб Дуб Вибілений Сонячний (2.179 м2)/9шт" & @CRLF & _
"137 Ламінат Vitality Style 4V 8/32 Дуб Вікторіанський Коричневий (2.179 м2)/9шт" & @CRLF & _
"138 Ламінат Vitality Style 4V 8/32 Дуб Натуральний Бежевий (2.179 м2)/9шт" & @CRLF & _
"145 Ламінат Vitality Style 4V 8/32 Дуб Модерн Білий (2.179 м2)/9шт" & @CRLF & _
"148 Ламінат Vitality Style 4V 8/32 Дуб Чорний (2.179 м2)/9шт" & @CRLF & _
"174 Ламінат Vitality Style 4V 8/32 Дуб Медовий (2.179 м2)/9шт" & @CRLF & _
"177 Ламінат Vitality Style 4V 8/32 Дуб Морозний (2.179 м2)/9шт" & @CRLF & _
"178 Ламінат Vitality Style 4V 8/32 Дуб Модерн Вишуканий (2.179 м2)/9шт" & @CRLF & _
"179 Ламінат Vitality Style 4V 8/32 Дуб Гірський Сірий (2.179 м2)/9шт" & @CRLF & _
"Vitality Style Aqua 4V" & @CRLF & _
"135 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Дуб Вибілений Сонячний" & @CRLF & _
"137 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Вікторіанський Коричневий " & @CRLF & _
"138 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Натуральний Бежевий" & @CRLF & _
"145 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Модерн Білий" & @CRLF & _
"148 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Чорний" & @CRLF & _
"149 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Сірий океан" & @CRLF & _
"174 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Медовий" & @CRLF & _
"175 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Брендон" & @CRLF & _
"177 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Морозний" & @CRLF & _
"178 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Модерн Вишуканий" & @CRLF & _
"179 Ламінат Vitality Style Aqua Protect 4V 8/32 Дуб Гірський Сірий" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")